9.16 on older platforms

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

9.16 on older platforms

Rick Dicaire
Hi folks, I have found that new dependencies for 9.16 prevent it being able to build on Slackware linux 14.2 (no ply or libuv).
(Yes I'm aware I can do the additional steps of downloading, compiling, installing the deps, but that's not the point)

It got meĀ thinking, are there other platforms where 9.16 will no longer build due to those missingĀ  deps?

_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users
Reply | Threaded
Open this post in threaded view
|

Re: 9.16 on older platforms

James Brown
On 20 Mar 2020, at 6:53 am, Rick Dicaire <[hidden email]> wrote:
>
> Hi folks, I have found that new dependencies for 9.16 prevent it being able to build on Slackware linux 14.2 (no ply or libuv).
> (Yes I'm aware I can do the additional steps of downloading, compiling, installing the deps, but that's not the point)
>
> It got me thinking, are there other platforms where 9.16 will no longer build due to those missing  deps?

macOS 10.12.6 Sierra.

Had to install autotools, edit autogen.sh from libuv source + other things.

James.
_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users

smime.p7s (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: 9.16 on older platforms

Jeff Wieland
In reply to this post by Rick Dicaire
James Brown wrote:

> On 20 Mar 2020, at 6:53 am, Rick Dicaire <[hidden email]> wrote:
>> Hi folks, I have found that new dependencies for 9.16 prevent it being able to build on Slackware linux 14.2 (no ply or libuv).
>> (Yes I'm aware I can do the additional steps of downloading, compiling, installing the deps, but that's not the point)
>>
>> It got me thinking, are there other platforms where 9.16 will no longer build due to those missing  deps?
> macOS 10.12.6 Sierra.
>
> Had to install autotools, edit autogen.sh from libuv source + other things.
>
> James.

Solaris 10 -- libuv missing, and libuv needs other packages.
I haven't had the time to get it all working yet.

--
Jeff Wieland, UNIX/Network Systems Administrator
Purdue University IT Infrastructure Services UNIX Platforms

_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users
Reply | Threaded
Open this post in threaded view
|

Re: 9.16 on older platforms

Chuck Aurora
In reply to this post by Rick Dicaire
On 2020-03-19 14:53, Rick Dicaire wrote:
> Hi folks, I have found that new dependencies for 9.16 prevent it
> being able to build on Slackware linux 14.2 (no ply or libuv).
> (Yes I'm aware I can do the additional steps of downloading,
> compiling, installing the deps, but that's not the point)

FWIW both libuv and ply are available on SlackBuilds.org for 14.2,
neither of which have any dependencies, so with a SBo frontend like
https://sbopkg.org/ , it would be a quick and easy install.

Of course you probably already know that 9.16 will be in Slackware's
15.0 release; a preview of which is in slackware(64)?-current at this
time.

14.2 is likely to remain a viable release for years to come, although
SBo will drop support when 15.0 is released.  It's usually trivial to
backport -current or later-release SBo slackbuild scripts to older
Slackware versions.
_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users