Problem with bind-9.11.15+: rbtdb.c:2097: INSIST

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem with bind-9.11.15+: rbtdb.c:2097: INSIST

Holger Wirtz
Hi all,

we have a strange problem with bind since version 9.11.15. I hoped this
would disappear with 9.11.17 but it did not :-(

We are running several binds on different VMs (Proxmox). Only on two of
them the problem occurs (both are secondary-only server, the third
secondary-only server does not show this problem). The server holds
about 4500 zones and serves about 300 queries/s. There is enough free
momory available.

After installation bind runs for some minutes and than you get the
following:

--- cut here ---
23-Mar-2020 09:17:43.934 rbtdb.c:2097: INSIST(!((void
*)((node)->deadlink.prev) != (void *)(-1))) failed, back trace
23-Mar-2020 09:17:43.934 #0 0x43fecd in ??
23-Mar-2020 09:17:43.934 #1 0x7f44795adcaa in ??
23-Mar-2020 09:17:43.934 #2 0x7f447a872da5 in ??
23-Mar-2020 09:17:43.934 #3 0x7f447a882d6c in ??
23-Mar-2020 09:17:43.934 #4 0x44e3fd in ??
23-Mar-2020 09:17:43.934 #5 0x4585b8 in ??
23-Mar-2020 09:17:43.934 #6 0x4353f6 in ??
23-Mar-2020 09:17:43.934 #7 0x7f44795d79c7 in ??
23-Mar-2020 09:17:43.934 #8 0x7f4478758064 in ??
23-Mar-2020 09:17:43.934 #9 0x7f447812662d in ??
23-Mar-2020 09:17:43.934 exiting (due to assertion failure)
--- cut here ---

For compilation is configured like this:

--- cut here ---
         ./configure --prefix=/usr \
                 --mandir=\$${prefix}/share/man \
                 --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
                 --infodir=\$${prefix}/share/info \
                 --sysconfdir=/etc/bind \
                 --with-python=python3 \
                 --localstatedir=/ \
                 --enable-threads \
                 --enable-largefile \
                 --with-libtool \
                 --enable-shared \
                 --enable-static \
                 --with-openssl=/usr \
                 --with-gssapi=/usr \
                 --with-gnu-ld \
                 --enable-ipv6 \
                 --enable-filter-aaaa
                 #--disable-atomic \
--- cut here ---

As you can see, I already tried what happens when using
"--disable-atomic"... but it also stops.

Also I tried to run configure with a smaller set of options:

--- cut here ---
         ./configure --prefix=/usr \
                 --mandir=\$${prefix}/share/man \
                 --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
                 --infodir=\$${prefix}/share/info \
                 --sysconfdir=/etc/bind
--- cut here ---

Currently I have absolute no idea what to do to fix this problem. Can
anybody help and show me the way how to go on?

TIA, Holger

--
#####  #### ##  ##  Holger Wirtz       SOV-Hotline: (+49 30) 884299-9115
##  ## ##   ### ##  DFN-Verein         Phone:       (+49 30) 884299-40
##  ## #### ######  Alexanderplatz 1   Fax:         (+49 30) 884299-70
##  ## ##   ## ###  10178 Berlin       E-Mail:      [hidden email]
#####  ##   ##  ##  GERMANY            WWW:         http://www.dfn.de
GPG-Fingerprint: ABFA 1F51 DD8D 503C 85DC  0C51 E961 79E2 6685 9BCF
_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users