Re: bind-users Digest, Vol 3172, Issue 4

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: bind-users Digest, Vol 3172, Issue 4

Ondřej Surý
Hi,

I can only second that. The default cc on OpenBSD comes from Precambrian era, so you’ll need to use at least gcc >= 4.8 or clang to fullfill the build requirements - see PLATFORMS.md.

We should probably asd a section on OpenBSD to the file and/or better checks to configure, but I always thought it’s a common knowledge that gcc from ports is needed to compile modern software.

Ondřej
--
Ondřej Surý — ISC

> On 28 Apr 2019, at 00:33, [hidden email] wrote:
>
> Send bind-users mailing list submissions to
>    [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>    https://lists.isc.org/mailman/listinfo/bind-users
> or, via email, send a message with subject or body 'help' to
>    [hidden email]
>
> You can reach the person managing the list at
>    [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of bind-users digest..."
> Today's Topics:
>
>   1. Re: Bind 9.14.1 will not build on OpenBSD 6.5 (amd64) (Mik J)
>   2. Re: Bind > 9.12 Will Not Start On FreeBSD (Tim Daneliuk)
>   3. Re: Bind > 9.12 Will Not Start On FreeBSD (Tim Daneliuk)
>   4. Re: Bind > 9.12 Will Not Start On FreeBSD (@lbutlr)
> <mime-attachment>
> <mime-attachment>
> <mime-attachment>
> <mime-attachment>
> _______________________________________________
> bind-users mailing list
> [hidden email]
> https://lists.isc.org/mailman/listinfo/bind-users

_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users
Reply | Threaded
Open this post in threaded view
|

Re: bind-users Digest, Vol 3172, Issue 4

Rich Kulawiec
On Sun, Apr 28, 2019 at 07:39:37AM +0200, Ond??ej Sur?? wrote:
> We should probably asd a section on OpenBSD to the file and/or better checks to configure, but I always thought it???s a common knowledge that gcc from ports is needed to compile modern software.

FYI, 9.11.6-P1 compiles and runs (as far as I can tell, correctly) on
OpenBSD 6.4, amd64 platform, using gcc 4.2.1.  However, if I install
the bin/named/client.c from:

        https://gitlab.isc.org/isc-projects/bind9/merge_requests/1864

the build breaks.  (It's possible that this is pilot error on my part,
and I apologize if that's the case.)

---rsk
_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users