request-nsid seems to not be working (Bind 9.11.3)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

request-nsid seems to not be working (Bind 9.11.3)

Bob McDonald
I have a server that has request-nsid yes; specified in the options block within named.conf. However, I don't see the NSID responses in the resolver channel log file. Anyone else see this behaviour? dig +nsid seems to work.

Regards,

Bob

_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users
Reply | Threaded
Open this post in threaded view
|

Re: request-nsid seems to not be working (Bind 9.11.3)

Tony Finch
Bob McDonald <[hidden email]> wrote:

> I have a server that has request-nsid yes; specified in the options block
> within named.conf. However, I don't see the NSID responses in the resolver
> channel log file.

It only appears at debug level 3 or greater.

Tony.
--
f.anthony.n.finch  <[hidden email]>  http://dotat.at/
Malin, South Hebrides: Northerly 5 at first in east Malin, otherwise variable
3 or 4. Slight or moderate. Fair. Good.
_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users
Reply | Threaded
Open this post in threaded view
|

Re: request-nsid seems to not be working (Bind 9.11.3)

Bob McDonald
Is that a functionality change from previous versions? I seem to remember it working at the info level.

I could be wrong...

On Wed, May 16, 2018 at 3:09 PM, Tony Finch <[hidden email]> wrote:
Bob McDonald <[hidden email]> wrote:

> I have a server that has request-nsid yes; specified in the options block
> within named.conf. However, I don't see the NSID responses in the resolver
> channel log file.

It only appears at debug level 3 or greater.

Tony.
--
f.anthony.n.finch  <[hidden email]http://dotat.at/
Malin, South Hebrides: Northerly 5 at first in east Malin, otherwise variable
3 or 4. Slight or moderate. Fair. Good.


_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users
Reply | Threaded
Open this post in threaded view
|

Re: request-nsid seems to not be working (Bind 9.11.3)

Bob McDonald
from the Bv9ARM: (9.11.3)

request-nsid
If yes, then an empty EDNS(0) NSID (Name Server Identifier) option is sent with all
queries to authoritative name servers during iterative resolution. If the authoritative
server returns an NSID option in its response, then its contents are logged in the resolver
category at level info. The default is no.

Seems to suggest that they get logged at the info level.

Regards,

Bob

On Wed, May 16, 2018 at 3:18 PM, Bob McDonald <[hidden email]> wrote:
Is that a functionality change from previous versions? I seem to remember it working at the info level.

I could be wrong...

On Wed, May 16, 2018 at 3:09 PM, Tony Finch <[hidden email]> wrote:
Bob McDonald <[hidden email]> wrote:

> I have a server that has request-nsid yes; specified in the options block
> within named.conf. However, I don't see the NSID responses in the resolver
> channel log file.

It only appears at debug level 3 or greater.

Tony.
--
f.anthony.n.finch  <[hidden email]http://dotat.at/
Malin, South Hebrides: Northerly 5 at first in east Malin, otherwise variable
3 or 4. Slight or moderate. Fair. Good.



_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users
Reply | Threaded
Open this post in threaded view
|

Re: request-nsid seems to not be working (Bind 9.11.3)

Tony Finch
In reply to this post by Bob McDonald
Bob McDonald <[hidden email]> wrote:

> Is that a functionality change from previous versions? I seem to remember
> it working at the info level.

It appears to be due to an unintended change. I've submitted a patch to fix it
https://gitlab.isc.org/isc-projects/bind9/merge_requests/290

Tony.
--
f.anthony.n.finch  <[hidden email]>  http://dotat.at/
harness technological change to human advantage
_______________________________________________
Please visit https://lists.isc.org/mailman/listinfo/bind-users to unsubscribe from this list

bind-users mailing list
[hidden email]
https://lists.isc.org/mailman/listinfo/bind-users